Стандарт доработки конфигурации

При доработке типовых модулей конфигурации необходимо обозначать комментариями изменения, которые были внесены программистом. При таком подходе проще после производить как отладку кода, так и перенос изменений при обновлении конфигурации на новый релиз.


// Фирма, Фамилия И.О., Дата // Цель изменений
// Старый код
Новый код 
// Конец  Фирма, Фамилия И.О., Дата // Цель изменений


В нашем случае для обозначения параметра «Фирма» будем использовать сокращенное название компании «OtusWise» как «OW». Оно же будет использовано в качестве префикса объектов метаданных и, если это необходимо, процедур или функций.

Новые объекты метаданных, добавленные нами, начинаются с «Префикс_ИмяОбъекта».

Пример:

Создаем общий модуль с именем «OW_ПроверкаЗаполнения» и в него записываем программный код следующего вида:


// OW, Порубай А.С., 22.01.2017 // Если пустое значение в строке колонки «Цена», заполняем Цену и Сумму значением 1.
Процедура ОбходПроверкиЗаполненияЦены(ТабличнаяЧасть, ИмяКолонкиЦена = «Цена», ИмяКолонкиСумма = «Сумма») Экспорт
     Для Каждого СтрокаДок Из ТабличнаяЧасть Цикл
              Если СтрокаДок[ИмяКолонкиЦена] = 0 Тогда
                    СтрокаДок[ИмяКолонкиЦена]  = 1;
                    СтрокаДок[ИмяКолонкиСумма] = 1;
               КонецЕсли;
     КонецЦикла;
КонецПроцедуры
// Конец OW, Порубай А.С., 22.01.2017 // Если пустое значение в строке колонки «Цена», заполняем Цену и Сумму значением 1.


Затем ссылаемся на него из модуля документа, или формы:


// OW, Порубай А.С., 22.01.2017 // Если пустое значение в строке колонки «Цена», заполняем Цену и Сумму значением 1.
OW_ПроверкаЗаполнения.ОбходПроверкиЗаполненияЦены(Товары);
// Конец OW, Порубай А.С., 22.07.2017 // Если пустое значение в строке колонки «Цена», заполняем Цену и Сумму значением 1.


Вот и все.